NetSign
CAC 5.5.128 (SP1) Auto-Decrypt Bug Report
NetSign CAC 5.5.128 (SP1)
Problem:
NetSign CAC 5.5.128 Auto-Decrypt feature with Outlook 2003 can cause
data loss if a user cancels an unsolicited PIN dialog after receiving
encrypted email message(s).
Summary:
Enabling the Auto-Decrypt feature for Email in NetSign CAC 5.5.128 with
Outlook 2003 can cause data loss if the user selects cancel when a PIN
dialog box pops up during an Outlook session. The problem occurs when a
user selects “cancel” to the PIN dialog even if the
user is not attempting to open an encrypted email message. The PIN
dialog has been seen to pop up between 1-15 minutes after an encrypted
email message has been received. If the correct PIN is not provided
then the Auto Decrypt feature in the NetSign middleware will
effectively delete the body of the message and any attachments.
Cause:
A bug was logged against NetSign CAC’s NsOlExt.dll, the
dynamic link library that manages configuring Outlook with the correct
CAC certificates used for secure messaging, registering certificates
for use with Internet Explorer, managing the email policies for signing
and encrypting messages as well as the Auto-Decrypt and Auto-contact
features.
Resolution:
Netsign CAC 5.5.129 contains the fix for this issue. Please contact Saflink Technical Support for details on how to obtain this release
Keywords:
Auto-Decrypt, NetSign CAC