NetSign CAC 5.5x Can't Read Smart Card -
Error 17
Article ID: KB00104
Last Review: June 26, 2006
Revision: 1.0
Product:
NetSign CAC 5x
Problem:
NetSign's System Info tool does not detect the Smart card reader is connected or functioning even though Smart Card Service did start ; and NetSign's System Diagnostic tool reports Error 17.
Summary:
Customers have reported errors with smart cards not functioning and reported that the Smart Card Service properties were somehow changed to Log on as "Local System account" instead of NT AUTHORITY\LocalService. The NetSign Cardstart.exe utility - System Info tab shows the following error: NetSign Library Information BSI Library Version 2,1,0,1 Could not get version from library. Error code 17 Status - failure
Cause:
It is unclear what the cause of this problem is, however what is clear is that somehow the Smart Card Services were changed from Log On as "NT AUTHORITY\LocalService" to Log on as Local System Account. The result is that the smart card reader is not being recognized when a user attempts to log into Windows. If they manually log into Windows, the NetSign CAC Cardstart.exe utility, System Info (tab), will not recognize a smart card reader connected to the system although the system's Device Manager will show that the smart card reader drivers are setup properly.
Resolution:
The proposed fix will require the local system Administrator to change Smart Card Service to start with NT AUTHORITY\LocalService.
Keywords: Error 17, smart card services, NetSign CAC, LocalService, KB00104